1

Closed

Could not install package WriteableBitmapEx because of "project that targets 'native,Version=v0.0'"

description

I am using WriteableBitmap on Windows Component Project (C++/CX) and want to include the WriteableBitmapEx for drawing like GDI+.

But, I cannot install this lib over NuGet. The error that I got is:

PM> Install-Package WriteableBitmapEx
Attempting to gather dependencies information for package 'WriteableBitmapEx.1.5.0' with respect to project 'base_utils\libUtils', targeting 'native,Version=v0.0'
Attempting to resolve dependencies for package 'WriteableBitmapEx.1.5.0' with DependencyBehavior 'Lowest'
Resolving actions to install package 'WriteableBitmapEx.1.5.0'
Resolved actions to install package 'WriteableBitmapEx.1.5.0'
Install failed. Rolling back...
Package 'WriteableBitmapEx.1.5.0 : ' does not exist in project 'libUtils'
Package 'WriteableBitmapEx.1.5.0 : ' does not exist in folder 'E:\PerforceData\1716\SPen5.0_UWP\SDK_UWP\build\packages'
Install-Package : Could not install package 'WriteableBitmapEx 1.5.0'. You are trying to install this package into a project that targets 'native,Version=v0.0', but the package does not contain any assembly references or content files that are compatible with
that framework. For more information, contact the package author.
At line:1 char:1
  • Install-Package WriteableBitmapEx
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : NotSpecified: (:) [Install-Package], Exception

+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

Has anybody got this problem before? And how can you comeover to it?
Closed Mar 23, 2016 at 6:29 AM by teichgraf
The lib is not built to be used for WinMD, therefore C# only at this point. For C++ I'd recommend other libs.

comments